Refactor: libcrmcommon: separate an "if" block in update_validation()
The code previously had logic like:
rc = pcmk_ok; if (transform) { ... } if (transform == FALSE || rc != pcmk_ok) { /* we need some progress! */ lpc++; }
The two cases in the last "if" are logically unrelated, and combining them
confuses what's happening. Move the "tranform == FALSE" case into an "else"
for the first "if", and move the "rc != pcmk_ok" case to the only place where
that's possible.