Refactor: scheduler: best practices when checking resource agent definition
Rename check_rsc_parameters() to pcmk__rsc_agent_changed() for clarity,
add a doxygen block, use bool instead of gboolean, use const where possible,
and improve comments, formatting, and variable names.
Also simplify the function to require fewer variables.