Page MenuHomeClusterLabs Projects

Pacemaker 3.0 Changes
Updated 10 Days AgoPublic

This describes proposed changes for a possible Pacemaker 3.0.0 release. Discussion should be directed to the users mailing list.

Pacemaker 3.0 is a proposed major release whose main goal is to remove support for deprecated legacy syntax, in order to improve code maintainability.

The expected time frame for the Pacemaker 3.0.0 release would be mid- to late 2024.

Release compatibility

  • Rolling upgrades from Pacemaker versions earlier than 2.0.0 are not supported. (Rolling upgrades from version 2.0.0 and greater should be possible with little to no change. Clusters with earlier versions can do a rolling upgrade to any Pacemaker 2 release and then another rolling upgrade to 3.0.0 or later.)
  • Cluster nodes running Pacemaker 3.0.0 or later will be unable to connect to Pacemaker Remote nodes running Pacemaker 1.1.14 or earlier.
  • Cluster nodes running a Pacemaker 1 release will be unable to connect to bundles or Pacemaker Remote nodes running Pacemaker 3.0.0 or later.

Proposed changes

Last Author
kgaillot
Last Edited
Wed, Jun 12, 12:30 PM